TOP

2018年2月21日 | テクノロジー

Xperiaがフルモデルチェンジ!?SONYがMWC向けティーザーを公開

2018年2月19日にSONYが、モバイルディバイス向けカンファレンス「Mobile WOrld Congress(MWC)」向けに新しいテ...

2018年2月21日 | テクノロジー

ポケモンGO、あと一週間でiPhone 5c以降のサポートを終了へ

Nianticが提供している「ポケモンGO」が、来週にあたる2018年3月1日をもって「iPhone 5c」以降のiOSディバイスのサポート...

2018年2月21日 | テクノロジー

新幹線、2018年5月より無料Wi-Fiの提供を開始へ – JR東日本

2018年2月21日にJR東日本が、新幹線の車内で無料のWi-Fiサービスを提供することを発表致しました。   &nb...

2018年2月20日 | テクノロジー

Apple、iOS 11.2.6をリリース! – 1文字送信でクラッシュする問題を修正

2018年2月20日にAppleが、バグ修正版として「iOS 11.2.6」を公開したことが明らかとなりました。   ...

2018年2月20日 | テクノロジー

SamsungのGalaxy S9/S9+のスペックがリーク – カラーバリエーションも

2018年2月20日にSamsungから販売予定の「Galaxy S9(ギャラクシーS9)」と「Galaxy S9+(ギャラクシーS9+)」...

2018年2月20日 | テクノロジー

Google、検索結果の画像一覧から「画像を表示」を削除

2018年2月20日にGoogleが、検索結果の画像一覧から画像を拡大表示できる「画像を表示」ボタンを削除していたことが明らかとなりました。...

2018年2月19日 | テクノロジー

はやくもGalaxy S10の情報がリーク! – 2Gbit秒のLTEモデルを採用か

2018年2月19日にSamsungの次期フラグシップスマートフォン「Galaxy S10」の情報が早くもリークされたことが明らかとなりまし...

2018年2月19日 | テクノロジー

Galaxy S9をハンズオンした人物が現る – 質問で詳細が明らかに

2018年2月19日にSamsungから販売予定の「Galaxy S9(ギャラクシーS9)」を20分間触ってきたユーザーが掲示版サイトに現れ...

2018年2月19日 | テクノロジー

ASUS、ZenFone 5へiPhone Xのようなノッチを採用か

2018年2月19日にASUSが、次期フラグシップスマートフォン「ZenFone 5(ゼンフォン5)」にて、Appleの「iPhone X」...

2018年2月18日 | テクノロジー

イオンモバイル、2018年3月からau回線のMVNOサービスを実施へ

2018年2月17日にイオンモバイルが、2018年3月より格安SIMサービスことMVNOとして、au回線の取扱を開始することが明らかとなりま...

2017年4月5日

Ruby、Ruby 2.1のサポートを終了へ

米国時間2017年4月1日にRubyコミュニティは、「Support of Ruby 2.1 has ended」において、Ruby 2.1系列バージョンのサポートを終了したことを発表した。

 

 

 

Ruby 2.1のサポート終了

Rubyとは、日本から誕生した数少ないプログラミング言語であり、オブジェクト指向言語となっている。

 

 

このオブジェクト指向の対応により、継承などオブジェクト指向ならではの機能が使えることが特徴的です。

 

 

 

Rubyコミュニティは、2016年3月末にRuby 2.1.10をリリースし、事実上Ruby 2.1系列はセキュリティメンテナンスフェーズに入っていた。

 

 

 

このセキュリティメンテナンスフェーズは、2017年3月31日をもって1年をもって満期を迎えたため、Ruby 2.1系列のサポートを終了することに踏み切ったようだ。

 

 

 

このRubyコミュニティの発表により、今後Ruby 2.1系列に脆弱性などを目的としたセキュリティパッチが公開されることは無いとされている。

 

 

 

Ruby 2.1 については、3月末までに予定されている 2.1.9 のリリースをもって通常メンテナンスを終了し、セキュリティメンテナンスに移行します。

これは、2.1.9 以降は重大なセキュリティ修正のみが行われ、単なるバグなどの修正が行われなくなることを意味します。

 

 

 

Rubyコミュニティは、Ruby 2.1系列を利用しているユーザーへ、Ruby 2.4系列または、Ruby 2.3系列へのアップグレードを推奨している。

 

 

 

なお、Rubyコミュニティによると現在サポートしているバージョンは以下の通りとなっている。

 

 

  • Ruby 2.4系列
  • Ruby 2.3系列
  • Ruby 2.2系列

 

 

Ruby 2.4系列とRuby 2.3系列は、通常のメンテナンスフェーズに位置づけられており、脆弱性のセキュリティパッチなどのサポートを通常通り提供されていくほか、バックポートも必要に応じて提供されていく。

 

 

 

しかしRuby 2.2系列は、現在セキュリティメンテナンスフェーズに位置づけられており、脆弱性に関するセキュリティパッチは今のところ提供されておりますが、バグ修正などのバックポートの配信はすでに終了している。

 

 

 

なお、重要度の高い脆弱性が発見された場合は、修正が施されたバージョンのリリースはされるようです。

 

 

 

また、Ruby 2.2系列のサポートの終了は、2018年3月末が予定されておりますので、ご注意ください。

 

出典元:Rubyコミュニティ

スポンサーリンク

あなたにおすすめの記事

この記事が気に入ったら
いいね!しよう

最新情報をお届けします

こちらの記事もおすすめ

         

カテゴリ

タグ

参加してます


お気軽にお書きください

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)